Ну что же, до экзаменов остаётся совсем мало времени. У тех девятиклассников, что сдают информатику очень часто затруднение вызывает задание под номером 19. На самом деле, это задание лишь кажется сложным. Если вы умеете работать с таблицами в программе Microsoft Office Excel, то легко сделаете это задание. Если же вы этого не умеете делать, то эта статья специально для вас. Сейчас я разберу 19 задание, для примера возьму задание из 1 варианта на РешуОГЭ. Нам дан файл task19.xls — откроем его. Перед нами список из 1000 разных продуктов и указано количество белков, жиров и углеводов, а также калорийность. Нам нужно выполнить два задания:

1. Сколь­ко про­дук­тов в таб­ли­це со­дер­жат мень­ше 50 г уг­ле­во­дов и мень­ше 50 г бел­ков? За­пи­ши­те число, обо­зна­ча­ю­щее ко­ли­че­ство этих про­дук­тов, в ячей­ку H2 таб­ли­цы.

2. Ка­ко­ва сред­няя ка­ло­рий­ность про­дук­тов с со­дер­жа­ни­ем жиров менее 1 г? За­пи­ши­те зна­че­ние в ячей­ку H3 таб­ли­цы с точ­но­стью не менее двух зна­ков после за­пя­той.

Для выполнения первого задания нам понадобится две формулы. Сначала мы запишем в ячейку F2 формулу: =ЕСЛИ(И(D2 <50; C2<50);1;0) она выведет 1, т.к. и белков и углеводов у арахиса меньше 50. Теперь скопируем эту формулу на весь столбик, для этого в нижнем правом углу ячейки F2 потяните вниз за зелёный квадратик до конца столбика. Мы получим целый столбик единиц и нулей. Теперь нужно найти их сумму и вписать в ячейку H2. Для этого введём в эту ячейку формулу суммы: =СУММ(F2:F1001) и получим число 864.

Теперь выполним второе задание, введём в ячейку H3 формулу =СУММЕСЛИ(B2:B1001; «<1″;E2:E1001)/СЧЁТЕСЛИ(B2:B1001;»<1») и получим 89,45. Задание №19 решено!